Document uploads failing

Incident Report for SchoolAI

Resolved

Document uploads appear to be working again, will continue to monitor
Posted May 27, 2026 - 10:22 MDT

Monitoring

We have implemented a fix and are monitoring.
Posted May 27, 2026 - 10:16 MDT

Update

A known issue causing multiple failures across the app related to File uploads, Create a Space, image generation, and Mission Control. We are identifying the root cause
Posted May 27, 2026 - 09:49 MDT

Investigating

We are currently investigating the issue
Posted May 27, 2026 - 09:46 MDT
This incident affected: Web Application (Frontend).